November 3rd, 2020

designer

О ретроградстве

В некоторых ситуациях, некоторые организации фиксируются на какомто стандарте и с ходом времен становятся все большими ретроградами. Друг сейчас написал, что у них газете по требованиям должно работать в IE11 т.к. он нужен для бухгалтерии или еще где. Браузера Internet Explorer давно нет, сама МС и похоронила, но он жив даже после смерти силами организаций, где когдато софт написали так, чтобы совместимо было только с ним.
Кажетя Лебедев как то писал, что долго искал и наконец то нашел новые трехдюймовые дискеты - именно на них требовалось сдавать какуюто там отчетность. Дело было давно но уже тогда дискеты были жутким анахронизмом, живой дисковод можно было найти разве что гдето в бездонных глубинах админских каптерок в особо древних организациях.

А мне сразу вспомнилась моя специфика - стоки.
У всех стоков стандартные требования по вектору - это EPS10, т.е. сохранено должно быть в версии программы Adobe Illustrator 10. Так вот, эти стандарты стоки (оглядываясь на главный тогда iStock) выбрали когда создавались - примерно в 2003-2005ых годах. Тогда EPS десятой версии Иллюстратора был разумным выбором - проге было около 5и лет, софт тогда покупался не подписками а каждый релиз продавался как отдельный продукт, ну или можно было купить апгрейд с прошлой версии но тоже дорого. Довольно многие организации работали на поза-прошлой или поза-поза прошлой версии софта пока реальность просто не заставляла их обновлятся. Ну как с компами до сих пор - не все же бегут за новым айфоном или там пересобирать системник сразу как выходит новый проц или новая версия айфона, большинство даже "энтузиастов" или выраженных геймеров пропускает по 1-3 поколения а некоторые сидят лет по 5-7 если железо все еще позволяет работать или играть.
Плюс с EPS есть всякие нюансы по поводу того, какую версию постскрипта могут печатать принтеры а принтеры (большие дорогие) меняют еще реже... вообщем, было оправдано выбрать относительно старенькую, хоть и не слишком версию для своего нового бизнеса.
Так вот, с тех пор прошло примерно 15 лет, а стандартом для работы на стоках остается EPS10 - уже ДВАДЦАТЕЛЕТНЕЙ, КАРЛ, давности стандарт. Адобы уже много лет как перешли на _только_ подписочную систему продажи, т.е. примерно 99% всех пользователей иллюстратора сейчас имеют автоматически обновляемую последнюю версию.
Ну т.е. представьте, что вам надо работать на 20 летней давности технике. МП3 плеер с памятью в 16Мегабайт (не гига, мега!) или там 2гб но это жесткий диск (уронил плеер - крякнул), кнопочный телефон с чб экраном и монофонией. Компьютер пентиум-3, 64мб оперативки. Телевизор с 32" экрана - это большой телевизор. Итд.
Страшно? А вот стоки по прежнему живут в этой эпохе.
В отсутствии какой либо серьезной конкуренции Люстра, конечно, остается одним из самых стагнирующих продуктов в мире (ну из популярных) но тем не менее, за 20 лет все же очень много чего прикрутили даже туда. А стоки очень активно держат нос по ветру в плане чего бы еще отрезать из отчислений стокерам в свою пользу, якобы всегда ищут "что же надо клиентам" выдавая инструкции как снимать и что снимать, но при этом упорно игнорят, что их стандарты контента давно покрылись мхом, и изрядно заржавели внутри. EPS10 и тьма ограничений в 2020 все еще те же, что в 2005ом. По началу еще было оправдание что _фото_стоки и к векторам относились как дешевым фоточкам. Но время то шло, ситуация сиииильно поменялась и епс10 по факту стал таким ядром прикованным к ноге авторов контента. А стоки это продолжают игнорить. Давно можно было разрешить и в растре расширенные возможности (например png или psd/tiff с поддержкой прозрачности чтобы изоляты были реально просто с вырезанным фоном) и уж в векторе то тем более. Но нет.

nb. Конечно, появились и стоки, которые специализируются не на простеньких картиночках а именно на сложных макетах юзающих все возможности актуальных версий, но много лет существуя на рынке они по прежнему остаются нишевыми на фоне грандов типа шатра. Хотя вот счас глянул на Adobe Stock (бывашая фотолия) как минимум в хелпе для авторов среди требований версия AI и EPS вообще убрана, там только "PDF совместимый файл". Правда не факт, что это все требования т.к. куча обязательных условий просто не описана (например нельзя растровые элементы но про это ни слова). Да и вообще, почти на всех стока хелп страница по техтребованиям - какойто пи-ц, куцые данные, часто жутко устаревшие/некорретные, например на 123rf гуглится страница требований со скринами допотопной версии файлзилы а версия епс требует аж 8. Хотя сто лет как прекрасно принимается 10ая.